Pixel Watch requires Android 8.0+, not mentioned iPhone support

Google today previewed its first smartwatch ahead of a fall launch alongside the Pixel 7 and 7 Pro. In doing so, Google noted that the Pixel Watch “requires an Android 8.0 or newer phone,” with no mention of iPhone support.

Wear OS 2 watches have long required “phones with Android 6.0+ (excluding Go edition) or iOS 13.0+”. The Galaxy Watch 4 had the same minimum Android requirement, even if Samsung uses its own Galaxy Wearable companion app.

Compatible with Android 6.0 or above, RAM 1.5GB above

Samsung

According to the fine print on the 16-second Pixel Watch “first sight” clip, Android 8.0 Oreo from 2017 (compared to Marshmallow from 2015) is required. Practically speaking, excluding Android 6, 7 and 7.1 doesn’t really exclude that many potential Pixel Watch owners.

Meanwhile, Google makes no mention of iPhone support for the Pixel Watch. This is similar to how the Galaxy Watch 4 was the first Wear OS device since 2015 to be incompatible with iOS. It remains to be seen whether this will also be the case for new third-party watches with Wear OS 3 later this year.

This is because an interview with Fitbit founder James Park on Wednesday said the company’s smartwatches and trackers would continue to work with iOS. Park had nothing to say about the Pixel Watch and iPhone, but that lack of support does give Fitbit a cross-platform differentiator.

More about Pixel:

FTC: We use auto affiliate links that generate revenue. More.


Check out 9to5Google on YouTube for more news:

Leave a Comment